re = /"fields":{(?<fields>[\w\W]+?)}/m
str = '{"records":[{"id":"recrsBYQ","createdTime":"2024-09-06T10:22:21.000Z","fields":{"fields1":"xyz","fields2":true}},{"id":"rec123XYZ","createdTime":"2024-09-07T12:00:00.000Z","fields":{"fields1":"abc","fields2":false}}]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end