using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""fields"":{(?<fields>[\w\W]+?)}";
string input = @"{""records"":[{""id"":""recrsBYQ"",""createdTime"":""2024-09-06T10:22:21.000Z"",""fields"":{""fields1"":""xyz"",""fields2"":true}},{""id"":""rec123XYZ"",""createdTime"":""2024-09-07T12:00:00.000Z"",""fields"":{""fields1"":""abc"",""fields2"":false}}]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}