#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^0[- ]*|[- ]+"
Local $sString = "0 800-204-4000" & @CRLF & _
"0800-204 4000" & @CRLF & _
"0 800 -204 - 4000" & @CRLF & _
"800 204 4000"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)