import re
regex = re.compile(r"^0[- ]*|[- ]+", flags=re.MULTILINE)
test_str = ("0 800-204-4000\n"
"0800-204 4000\n"
"0 800 -204 - 4000\n"
"800 204 4000")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)