using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0[- ]*|[- ]+";
string substitution = @"";
string input = @"0 800-204-4000
0800-204 4000
0 800 -204 - 4000
800 204 4000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}