// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0[- ]*|[- ]+").unwrap();
let string = "0 800-204-4000
0800-204 4000
0 800 -204 - 4000
800 204 4000";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}