$re = '/^0[- ]*|[- ]+/m';
$str = '0 800-204-4000
0800-204 4000
0 800 -204 - 4000
800 204 4000';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;