re = /^0[- ]*|[- ]+/m
str = '0 800-204-4000
0800-204 4000
0 800 -204 - 4000
800 204 4000'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result