using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^""'\n]*(?:""(?:[^""\n]|"")*""))*[^""]*'(.*)$";
string input = @"Working - This is a test 'This should be captured
Working - ""this is a test"" 'This should be captured
Not Working - ""this is a test"" 'This should be ""captured""
Not Working - This is a test 'This should be ""captured""
Working - ""this is a test 'this should not capture'"" 'this should capture
Working - ""this isn't a test"" 'this should capture
And ""this""? Does it ""work"" or doesn't it? ' Comment
""Having ""quoted"" quotes couldn't work, could they""? ""Yeah, they do!"" ' Great";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}