package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^"'\n]*(?:"(?:[^"\n]|"")*"))*[^"]*'(.*)$`)
var str = `Working - This is a test 'This should be captured
Working - "this is a test" 'This should be captured
Not Working - "this is a test" 'This should be "captured"
Not Working - This is a test 'This should be "captured"
Working - "this is a test 'this should not capture'" 'this should capture
Working - "this isn't a test" 'this should capture
And "this"? Does it "work" or doesn't it? ' Comment
"Having ""quoted"" quotes couldn't work, could they"? "Yeah, they do!" ' Great`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}