const regex = /^(?:[^"'\n]*(?:"(?:[^"\n]|"")*"))*[^"]*'(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^"\'\\n]*(?:"(?:[^"\\n]|"")*"))*[^"]*\'(.*)$', 'gm')
const str = `Working - This is a test 'This should be captured
Working - "this is a test" 'This should be captured
Not Working - "this is a test" 'This should be "captured"
Not Working - This is a test 'This should be "captured"
Working - "this is a test 'this should not capture'" 'this should capture
Working - "this isn't a test" 'this should capture
And "this"? Does it "work" or doesn't it? ' Comment
"Having ""quoted"" quotes couldn't work, could they"? "Yeah, they do!" ' Great`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}