import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^\"'\\n]*(?:\"(?:[^\"\\n]|\"\")*\"))*[^\"]*'(.*)$";
final String string = "Working - This is a test 'This should be captured\n"
+ "Working - \"this is a test\" 'This should be captured\n"
+ "Not Working - \"this is a test\" 'This should be \"captured\"\n"
+ "Not Working - This is a test 'This should be \"captured\"\n"
+ "Working - \"this is a test 'this should not capture'\" 'this should capture\n"
+ "Working - \"this isn't a test\" 'this should capture\n"
+ "And \"this\"? Does it \"work\" or doesn't it? ' Comment\n"
+ "\"Having \"\"quoted\"\" quotes couldn't work, could they\"? \"Yeah, they do!\" ' Great";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}