# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((`{3}\\\\s*)(\\\\w+)?(\\\\s*([\\\\w\\\\W]+?)\\\\n*)\\\\2)\\\\n*(?:[^\\\\S\\\\w\\\\s]|$)
/:/g;t' <<< "\documentclass[12pt]{article}
\title{Memoria}
\author{Jose Serodio Ignacio}
\usepackage[spanish, activeacute]{babel} % Definir idioma español
\usepackage[utf8]{inputenc} % Codificación utf-8
\begin{document}
\maketitle
\section{Introducción}
% Descripción y situación del trabajo
Industria de Turbo Propulsores (en adelante ITP) es una empresa asca dedicad
al diseño y fabricación de motores aeronáuticos y turbinas de gas.\\"