re = /^((`{3}\\\\s*)(\\\\w+)?(\\\\s*([\\\\w\\\\W]+?)\\\\n*)\\\\2)\\\\n*(?:[^\\\\S\\\\w\\\\s]|$)
/
str = '\\documentclass[12pt]{article}
\\title{Memoria}
\\author{Jose Serodio Ignacio}
\\usepackage[spanish, activeacute]{babel} % Definir idioma español
\\usepackage[utf8]{inputenc} % Codificación utf-8
\\begin{document}
\\maketitle
\\section{Introducción}
% Descripción y situación del trabajo
Industria de Turbo Propulsores (en adelante ITP) es una empresa asca dedicad
al diseño y fabricación de motores aeronáuticos y turbinas de gas.\\\\'
subst = ':'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result