using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((`{3}\\\\s*)(\\\\w+)?(\\\\s*([\\\\w\\\\W]+?)\\\\n*)\\\\2)\\\\n*(?:[^\\\\S\\\\w\\\\s]|$)
";
string substitution = @":";
string input = @"\documentclass[12pt]{article}
\title{Memoria}
\author{Jose Serodio Ignacio}
\usepackage[spanish, activeacute]{babel} % Definir idioma español
\usepackage[utf8]{inputenc} % Codificación utf-8
\begin{document}
\maketitle
\section{Introducción}
% Descripción y situación del trabajo
Industria de Turbo Propulsores (en adelante ITP) es una empresa asca dedicad
al diseño y fabricación de motores aeronáuticos y turbinas de gas.\\";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}