import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((`{3}\\\\\\\\s*)(\\\\\\\\w+)?(\\\\\\\\s*([\\\\\\\\w\\\\\\\\W]+?)\\\\\\\\n*)\\\\\\\\2)\\\\\\\\n*(?:[^\\\\\\\\S\\\\\\\\w\\\\\\\\s]|$)\n";
final String string = "\\documentclass[12pt]{article}\n"
+ "\\title{Memoria}\n"
+ "\\author{Jose Serodio Ignacio}\n"
+ "\\usepackage[spanish, activeacute]{babel} % Definir idioma español\n"
+ "\\usepackage[utf8]{inputenc} % Codificación utf-8\n\n"
+ "\\begin{document}\n\n"
+ "\\maketitle\n\n"
+ "\\section{Introducción}\n"
+ "% Descripción y situación del trabajo\n"
+ "Industria de Turbo Propulsores (en adelante ITP) es una empresa asca dedicad\n"
+ "al diseño y fabricación de motores aeronáuticos y turbinas de gas.\\\\";
final String subst = ":";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}