const regex = /^((`{3}\\\\s*)(\\\\w+)?(\\\\s*([\\\\w\\\\W]+?)\\\\n*)\\\\2)\\\\n*(?:[^\\\\S\\\\w\\\\s]|$)
/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((`{3}\\\\\\\\s*)(\\\\\\\\w+)?(\\\\\\\\s*([\\\\\\\\w\\\\\\\\W]+?)\\\\\\\\n*)\\\\\\\\2)\\\\\\\\n*(?:[^\\\\\\\\S\\\\\\\\w\\\\\\\\s]|$)
', 'g')
const str = `\\documentclass[12pt]{article}
\\title{Memoria}
\\author{Jose Serodio Ignacio}
\\usepackage[spanish, activeacute]{babel} % Definir idioma español
\\usepackage[utf8]{inputenc} % Codificación utf-8
\\begin{document}
\\maketitle
\\section{Introducción}
% Descripción y situación del trabajo
Industria de Turbo Propulsores (en adelante ITP) es una empresa asca dedicad
al diseño y fabricación de motores aeronáuticos y turbinas de gas.\\\\`;
const subst = `:`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);