import re
regex = re.compile((r"^((`{3}\\\\s*)(\\\\w+)?(\\\\s*([\\\\w\\\\W]+?)\\\\n*)\\\\2)\\\\n*(?:[^\\\\S\\\\w\\\\s]|$)\n"))
test_str = ("\\documentclass[12pt]{article}\n"
"\\title{Memoria}\n"
"\\author{Jose Serodio Ignacio}\n"
"\\usepackage[spanish, activeacute]{babel} % Definir idioma español\n"
"\\usepackage[utf8]{inputenc} % Codificación utf-8\n\n"
"\\begin{document}\n\n"
"\\maketitle\n\n"
"\\section{Introducción}\n"
"% Descripción y situación del trabajo\n"
"Industria de Turbo Propulsores (en adelante ITP) es una empresa asca dedicad\n"
"al diseño y fabricación de motores aeronáuticos y turbinas de gas.\\\\")
subst = ":"
result = regex.sub(subst, test_str)
if result:
print(result)