const regex = new RegExp('(\\[(?P<datetime>.+)\\]\\[(?P<thread>[^\\]]+)\\])?(?P<subsystem>.+?):\\s*((?P<level>Fatal|Error|Warning|Log):\\s?)?(?P<msg>.+)', 'gm')
const str = `[2022.01.14-17.23.19:799][710]LogNet: Login request: ?DisplayName=aa?UserRole=1 userId: UNKNOWN platform: IOS
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}