$re = '`(\[(?P<datetime>.+)\]\[(?P<thread>[^\]]+)\])?(?P<subsystem>.+?):\s*((?P<level>Fatal|Error|Warning|Log):\s?)?(?P<msg>.+)`m';
$str = '[2022.01.14-17.23.19:799][710]LogNet: Login request: ?DisplayName=aa?UserRole=1 userId: UNKNOWN platform: IOS
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);