import re
regex = re.compile(r"(\[(?P<datetime>.+)\]\[(?P<thread>[^\]]+)\])?(?P<subsystem>.+?):\s*((?P<level>Fatal|Error|Warning|Log):\s?)?(?P<msg>.+)", flags=re.MULTILINE)
test_str = ("[2022.01.14-17.23.19:799][710]LogNet: Login request: ?DisplayName=aa?UserRole=1 userId: UNKNOWN platform: IOS\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")