use strict;
my $str = '[2022.01.14-17.23.19:799][710]LogNet: Login request: ?DisplayName=aa?UserRole=1 userId: UNKNOWN platform: IOS
';
my $regex = qr`(\[(?P<datetime>.+)\]\[(?P<thread>[^\]]+)\])?(?P<subsystem>.+?):\s*((?P<level>Fatal|Error|Warning|Log):\s?)?(?P<msg>.+)`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}