re = /(\[(?P<datetime>.+)\]\[(?P<thread>[^\]]+)\])?(?P<subsystem>.+?):\s*((?P<level>Fatal|Error|Warning|Log):\s?)?(?P<msg>.+)/m
str = '[2022.01.14-17.23.19:799][710]LogNet: Login request: ?DisplayName=aa?UserRole=1 userId: UNKNOWN platform: IOS
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end