const regex = /(https:\/\/)(\S*)(gmail-getter)([\w\/\?\=\-]*)/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https:\\\/\\\/)(\\S*)(gmail-getter)([\\w\\\/\\?\\=\\-]*)', 'im')
const str = `<a href="https://github.com/bormando/gmail-getter" style="background-color:#1a73e8;padding:10px 20px;color:white;text-decoration:none;font-size:15px;font-family:Roboto,sans-serif;border-radius:5px;display:block;margin:20px 0;width:120px" target="_blank" data-saferedirecturl="https://www.google.com/url?q=https://github.com/bormando/gmail-getter&source=gmail&ust=1676575529886000&usg=AOvVaw3PvSPg737yxc1HKqHXUJWk">GitHub
</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}