import re
regex = re.compile(r"(https:\/\/)(\S*)(gmail-getter)([\w\/\?\=\-]*)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("<a href=\"https://github.com/bormando/gmail-getter\" style=\"background-color:#1a73e8;padding:10px 20px;color:white;text-decoration:none;font-size:15px;font-family:Roboto,sans-serif;border-radius:5px;display:block;margin:20px 0;width:120px\" target=\"_blank\" data-saferedirecturl=\"https://www.google.com/url?q=https://github.com/bormando/gmail-getter&source=gmail&ust=1676575529886000&usg=AOvVaw3PvSPg737yxc1HKqHXUJWk\">GitHub\n"
"</a>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")