re = /(https:\/\/)(\S*)(gmail-getter)([\w\/\?\=\-]*)/im
str = '<a href="https://github.com/bormando/gmail-getter" style="background-color:#1a73e8;padding:10px 20px;color:white;text-decoration:none;font-size:15px;font-family:Roboto,sans-serif;border-radius:5px;display:block;margin:20px 0;width:120px" target="_blank" data-saferedirecturl="https://www.google.com/url?q=https://github.com/bormando/gmail-getter&source=gmail&ust=1676575529886000&usg=AOvVaw3PvSPg737yxc1HKqHXUJWk">GitHub
</a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end