import Foundation
let pattern = #"(https:\/\/)(\S*)(gmail-getter)([\w\/\?\=\-]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
<a href="https://github.com/bormando/gmail-getter" style="background-color:#1a73e8;padding:10px 20px;color:white;text-decoration:none;font-size:15px;font-family:Roboto,sans-serif;border-radius:5px;display:block;margin:20px 0;width:120px" target="_blank" data-saferedirecturl="https://www.google.com/url?q=https://github.com/bormando/gmail-getter&source=gmail&ust=1676575529886000&usg=AOvVaw3PvSPg737yxc1HKqHXUJWk">GitHub
</a>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}