#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+[^\/ajax\/]\/)?([^\/]+[^index.cfm]).cfm$"
Local $sString = "http://mysite.com/contact" & @CRLF & _
"http://mysite.com/index.cfm?p=contact" & @CRLF & _
"http://mysite.com/contact.cfm" & @CRLF & _
"http://mysite.com/ajax/contact-form.cfm" & @CRLF & _
"http://mysite.com/index.cfm?p=contact.cfm" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")