// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.+[^\/ajax\/]\/)?([^\/]+[^index.cfm]).cfm$").unwrap();
let string = "http://mysite.com/contact
http://mysite.com/index.cfm?p=contact
http://mysite.com/contact.cfm
http://mysite.com/ajax/contact-form.cfm
http://mysite.com/index.cfm?p=contact.cfm
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}