$re = '/^(.+[^\/ajax\/]\/)?([^\/]+[^index.cfm]).cfm$/m';
$str = 'http://mysite.com/contact
http://mysite.com/index.cfm?p=contact
http://mysite.com/contact.cfm
http://mysite.com/ajax/contact-form.cfm
http://mysite.com/index.cfm?p=contact.cfm
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);