re = /^(.+[^\/ajax\/]\/)?([^\/]+[^index.cfm]).cfm$/m
str = 'http://mysite.com/contact
http://mysite.com/index.cfm?p=contact
http://mysite.com/contact.cfm
http://mysite.com/ajax/contact-form.cfm
http://mysite.com/index.cfm?p=contact.cfm
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end