#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[+-]?((\d+(\.\d*)?)|((\d*\.\d+)))(e[-+]?\d*)?"
Local $sString = ".123e123" & @CRLF & _
".123e+123" & @CRLF & _
".123e-123" & @CRLF & _
"" & @CRLF & _
"123.e123" & @CRLF & _
"123.e+123" & @CRLF & _
"123.e-123" & @CRLF & _
"" & @CRLF & _
"123.123e123" & @CRLF & _
"123.123e+123" & @CRLF & _
"123.123e-123" & @CRLF & _
"" & @CRLF & _
".e1" & @CRLF & _
".1e1.2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")