package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[+-]?((\d+(\.\d*)?)|((\d*\.\d+)))(e[-+]?\d*)?`)
var str = `.123e123
.123e+123
.123e-123
123.e123
123.e+123
123.e-123
123.123e123
123.123e+123
123.123e-123
.e1
.1e1.2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}