re = /[+-]?((\d+(\.\d*)?)|((\d*\.\d+)))(e[-+]?\d*)?/m
str = '.123e123
.123e+123
.123e-123
123.e123
123.e+123
123.e-123
123.123e123
123.123e+123
123.123e-123
.e1
.1e1.2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end