const regex = /[+-]?((\d+(\.\d*)?)|((\d*\.\d+)))(e[-+]?\d*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[+-]?((\\d+(\\.\\d*)?)|((\\d*\\.\\d+)))(e[-+]?\\d*)?', 'gm')
const str = `.123e123
.123e+123
.123e-123
123.e123
123.e+123
123.e-123
123.123e123
123.123e+123
123.123e-123
.e1
.1e1.2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}