$re = '/[+-]?((\d+(\.\d*)?)|((\d*\.\d+)))(e[-+]?\d*)?/m';
$str = '.123e123
.123e+123
.123e-123
123.e123
123.e+123
123.e-123
123.123e123
123.123e+123
123.123e-123
.e1
.1e1.2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);