#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?\.([\w-]+\.[\w-]+\.[\w-]+)$"
Local $sString = "web1.com" & @CRLF & _
"test.web2.com" & @CRLF & _
"www.test.web3.com" & @CRLF & _
"baz.f-o-o.b-ar.com" & @CRLF & _
"" & @CRLF & _
"a.b.c.d" & @CRLF & _
"a.b.c.d.e" & @CRLF & _
"a.b.c.d.e.f" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)