use strict;
my $str = 'web1.com
test.web2.com
www.test.web3.com
baz.f-o-o.b-ar.com
a.b.c.d
a.b.c.d.e
a.b.c.d.e.f
';
my $regex = qr/^.*?\.([\w-]+\.[\w-]+\.[\w-]+)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";