import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\.([\\w-]+\\.[\\w-]+\\.[\\w-]+)$";
final String string = "web1.com\n"
+ "test.web2.com\n"
+ "www.test.web3.com\n"
+ "baz.f-o-o.b-ar.com\n\n"
+ "a.b.c.d\n"
+ "a.b.c.d.e\n"
+ "a.b.c.d.e.f\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}