$re = '/^.*?\.([\w-]+\.[\w-]+\.[\w-]+)$/m';
$str = 'web1.com
test.web2.com
www.test.web3.com
baz.f-o-o.b-ar.com
a.b.c.d
a.b.c.d.e
a.b.c.d.e.f
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;