const regex = /^.*?\.([\w-]+\.[\w-]+\.[\w-]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?\\.([\\w-]+\\.[\\w-]+\\.[\\w-]+)$', 'gm')
const str = `web1.com
test.web2.com
www.test.web3.com
baz.f-o-o.b-ar.com
a.b.c.d
a.b.c.d.e
a.b.c.d.e.f
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);