re = /^.*?\.([\w-]+\.[\w-]+\.[\w-]+)$/m
str = 'web1.com
test.web2.com
www.test.web3.com
baz.f-o-o.b-ar.com
a.b.c.d
a.b.c.d.e
a.b.c.d.e.f
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result