#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[.+?=(\d+)\]"
Local $sString = "Units Currently On Bed List [total beds=0] Number Of Beds Unit Interval Select All " & @CRLF & _
"Units Currently On Bed List [total beds=10] Number Of Beds Unit Interval Select All " & @CRLF & _
"Units Currently On Bed List [total beds=] Number Of Beds Unit Interval Select All " & @CRLF & _
"Units Currently On Bed List [total beds=999] Number Of Beds Unit Interval Select All "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")