// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[.+?=(\d+)\]").unwrap();
let string = "Units Currently On Bed List [total beds=0] Number Of Beds Unit Interval Select All
Units Currently On Bed List [total beds=10] Number Of Beds Unit Interval Select All
Units Currently On Bed List [total beds=] Number Of Beds Unit Interval Select All
Units Currently On Bed List [total beds=999] Number Of Beds Unit Interval Select All ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}