$re = '/\[.+?=(\d+)\]/';
$str = 'Units Currently On Bed List [total beds=0] Number Of Beds Unit Interval Select All
Units Currently On Bed List [total beds=10] Number Of Beds Unit Interval Select All
Units Currently On Bed List [total beds=] Number Of Beds Unit Interval Select All
Units Currently On Bed List [total beds=999] Number Of Beds Unit Interval Select All ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);