import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[.+?=(\\d+)\\]";
final String string = "Units Currently On Bed List [total beds=0] Number Of Beds Unit Interval Select All \n"
+ "Units Currently On Bed List [total beds=10] Number Of Beds Unit Interval Select All \n"
+ "Units Currently On Bed List [total beds=] Number Of Beds Unit Interval Select All \n"
+ "Units Currently On Bed List [total beds=999] Number Of Beds Unit Interval Select All ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}