import re
regex = re.compile(r"\[.+?=(\d+)\]")
test_str = ("Units Currently On Bed List [total beds=0] Number Of Beds Unit Interval Select All \n"
"Units Currently On Bed List [total beds=10] Number Of Beds Unit Interval Select All \n"
"Units Currently On Bed List [total beds=] Number Of Beds Unit Interval Select All \n"
"Units Currently On Bed List [total beds=999] Number Of Beds Unit Interval Select All ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")