using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[.+?=(\d+)\]";
string input = @"Units Currently On Bed List [total beds=0] Number Of Beds Unit Interval Select All
Units Currently On Bed List [total beds=10] Number Of Beds Unit Interval Select All
Units Currently On Bed List [total beds=] Number Of Beds Unit Interval Select All
Units Currently On Bed List [total beds=999] Number Of Beds Unit Interval Select All ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}