#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "3[7-9]|[4-9]\d+|[1-9]\d{2,}"
Local $sString = "Items 1 to 36 of 605 total" & @CRLF & _
"Items 1 to 36 of 117 total" & @CRLF & _
"Items 1 to 36 of 74 total" & @CRLF & _
"" & @CRLF & _
"37" & @CRLF & _
"38" & @CRLF & _
"39"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")