using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"3[7-9]|[4-9]\d+|[1-9]\d{2,}";
string input = @"Items 1 to 36 of 605 total
Items 1 to 36 of 117 total
Items 1 to 36 of 74 total
37
38
39";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}